import Foundation
let pattern = #"[-+]?(?:\d+(?:\.\d*)?|\.\d+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
123
sfg44
sgf -123
1
+1
113
12324
-
+
sfgsfsg 113.13
.13 ssgfsf
-.23
-0.23
sfgsgf -134.14
+14.14
sfv
+sfv
-sfv
-3.1
.
100%
hsl(171, 100%, 92%)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)