use strict;
my $str = '
123
sfg44
sgf -123
1
+1
113
12324
-
+
sfgsfsg 113.13
.13 ssgfsf
-.23
-0.23
sfgsgf -134.14
+14.14
sfv
+sfv
-sfv
-3.1
.
100%
hsl(171, 100%, 92%)
';
my $regex = qr/[-+]?(?:\d+(?:\.\d*)?|\.\d+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}