package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[-+]?(?:\d+(?:\.\d*)?|\.\d+)`)
var str = `
123
sfg44
sgf -123
1
+1
113
12324
-
+
sfgsfsg 113.13
.13 ssgfsf
-.23
-0.23
sfgsgf -134.14
+14.14
sfv
+sfv
-sfv
-3.1
.
100%
hsl(171, 100%, 92%)
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}