import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\S+) (?=(?s:.)*\\1.*).*";
final String string = "user1 jul/12/12\n"
+ "user5 jul/13/13\n"
+ "user1 jul/14/12\n"
+ "user1 jul/12/12\n"
+ "user5 jul/13/13\n"
+ "user1 jul/14/12\n"
+ "user3 jan/12/12\n"
+ "user1 jul/12/12\n"
+ "user5 jul/13/13\n"
+ "user1 jul/14/12\n"
+ "user1 jul/12/12\n"
+ "user5 jul/13/13\n"
+ "user1 jul/14/12\n"
+ "user1 jul/12/12\n"
+ "user6 aug/06/06\n"
+ "user5 jul/13/13\n"
+ "user1 jul/14/12\n"
+ "user1 jul/12/12\n"
+ "user5 jul/13/13\n"
+ "user1 jul/14/12\n"
+ "user1 aug/12/12\n"
+ "user5 feb/13/13\n"
+ "user1 dec/14/12\n"
+ "user1 jul/12/12\n"
+ "user5 jul/13/13\n"
+ "user1 jul/14/12\n"
+ "user2 jun/15/14";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}