# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(\S+) (?=(?s:.)*\1.*).*"
test_str = ("user1 jul/12/12\n"
"user5 jul/13/13\n"
"user1 jul/14/12\n"
"user1 jul/12/12\n"
"user5 jul/13/13\n"
"user1 jul/14/12\n"
"user3 jan/12/12\n"
"user1 jul/12/12\n"
"user5 jul/13/13\n"
"user1 jul/14/12\n"
"user1 jul/12/12\n"
"user5 jul/13/13\n"
"user1 jul/14/12\n"
"user1 jul/12/12\n"
"user6 aug/06/06\n"
"user5 jul/13/13\n"
"user1 jul/14/12\n"
"user1 jul/12/12\n"
"user5 jul/13/13\n"
"user1 jul/14/12\n"
"user1 aug/12/12\n"
"user5 feb/13/13\n"
"user1 dec/14/12\n"
"user1 jul/12/12\n"
"user5 jul/13/13\n"
"user1 jul/14/12\n"
"user2 jun/15/14")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.