$re = '/^(\S+) (?=(?s:.)*\1.*).*/m';
$str = 'user1 jul/12/12
user5 jul/13/13
user1 jul/14/12
user1 jul/12/12
user5 jul/13/13
user1 jul/14/12
user3 jan/12/12
user1 jul/12/12
user5 jul/13/13
user1 jul/14/12
user1 jul/12/12
user5 jul/13/13
user1 jul/14/12
user1 jul/12/12
user6 aug/06/06
user5 jul/13/13
user1 jul/14/12
user1 jul/12/12
user5 jul/13/13
user1 jul/14/12
user1 aug/12/12
user5 feb/13/13
user1 dec/14/12
user1 jul/12/12
user5 jul/13/13
user1 jul/14/12
user2 jun/15/14';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);