import Foundation
let pattern = #"^(\S+) (?=(?s:.)*\1.*).*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
user1 jul/12/12
user5 jul/13/13
user1 jul/14/12
user1 jul/12/12
user5 jul/13/13
user1 jul/14/12
user3 jan/12/12
user1 jul/12/12
user5 jul/13/13
user1 jul/14/12
user1 jul/12/12
user5 jul/13/13
user1 jul/14/12
user1 jul/12/12
user6 aug/06/06
user5 jul/13/13
user1 jul/14/12
user1 jul/12/12
user5 jul/13/13
user1 jul/14/12
user1 aug/12/12
user5 feb/13/13
user1 dec/14/12
user1 jul/12/12
user5 jul/13/13
user1 jul/14/12
user2 jun/15/14
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)