const regex = /^(\S+) (?=(?s:.)*\1.*).*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\S+) (?=(?s:.)*\\1.*).*', 'gm')
const str = `user1 jul/12/12
user5 jul/13/13
user1 jul/14/12
user1 jul/12/12
user5 jul/13/13
user1 jul/14/12
user3 jan/12/12
user1 jul/12/12
user5 jul/13/13
user1 jul/14/12
user1 jul/12/12
user5 jul/13/13
user1 jul/14/12
user1 jul/12/12
user6 aug/06/06
user5 jul/13/13
user1 jul/14/12
user1 jul/12/12
user5 jul/13/13
user1 jul/14/12
user1 aug/12/12
user5 feb/13/13
user1 dec/14/12
user1 jul/12/12
user5 jul/13/13
user1 jul/14/12
user2 jun/15/14`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}