#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\h*(?|(\[[^]]+](?:\h*\[[^]]+])*+)\h*+([^[\n]*(?<=\S))|()([^[\n]*[^\s[]))"
Local $sString = "[C#]I’m looking for [Fm]you [G#]" & @CRLF & _
"bluh blih" & @CRLF & _
"[C#] [Fm] [G#]" & @CRLF & _
"[C#] [Fm] [G#] blah blih bloh" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")