$re = '/\h*(?|(\[[^]]+](?:\h*\[[^]]+])*+)\h*+([^[\n]*(?<=\S))|()([^[\n]*[^\s[]))/';
$str = '[C#]I’m looking for [Fm]you [G#]
bluh blih
[C#] [Fm] [G#]
[C#] [Fm] [G#] blah blih bloh
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);