re = /\h*(?|(\[[^]]+](?:\h*\[[^]]+])*+)\h*+([^[\n]*(?<=\S))|()([^[\n]*[^\s[]))/
str = '[C#]I’m looking for [Fm]you [G#]
bluh blih
[C#] [Fm] [G#]
[C#] [Fm] [G#] blah blih bloh
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end