using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\h*(?|(\[[^]]+](?:\h*\[[^]]+])*+)\h*+([^[\n]*(?<=\S))|()([^[\n]*[^\s[]))";
string input = @"[C#]I’m looking for [Fm]you [G#]
bluh blih
[C#] [Fm] [G#]
[C#] [Fm] [G#] blah blih bloh
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}