const regex = /\h*(?|(\[[^]]+](?:\h*\[[^]]+])*+)\h*+([^[\n]*(?<=\S))|()([^[\n]*[^\s[]))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\h*(?|(\\[[^]]+](?:\\h*\\[[^]]+])*+)\\h*+([^[\\n]*(?<=\\S))|()([^[\\n]*[^\\s[]))', 'g')
const str = `[C#]I’m looking for [Fm]you [G#]
bluh blih
[C#] [Fm] [G#]
[C#] [Fm] [G#] blah blih bloh
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}