#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<html(?![^<>]* (?:amp|⚡)[ >])"
Local $sString = "<!doctype html><html><head>" & @CRLF & _
"<!doctype html><html ⚡><head>" & @CRLF & _
"<!doctype html><html ⚡ lang=en><head>" & @CRLF & _
"<!doctype html><html lang=en ⚡><head>" & @CRLF & _
"<!doctype html><html amp><head>" & @CRLF & _
"<!doctype html><html amp lang=en><head>" & @CRLF & _
"<!doctype html><html lang=en amp><head>" & @CRLF & _
"<!doctype html><html lang=en abc><head>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")