using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<html(?![^<>]* (?:amp|⚡)[ >])";
string input = @"<!doctype html><html><head>
<!doctype html><html ⚡><head>
<!doctype html><html ⚡ lang=en><head>
<!doctype html><html lang=en ⚡><head>
<!doctype html><html amp><head>
<!doctype html><html amp lang=en><head>
<!doctype html><html lang=en amp><head>
<!doctype html><html lang=en abc><head>
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}