import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<html(?![^<>]* (?:amp|⚡)[ >])";
final String string = "<!doctype html><html><head>\n"
+ "<!doctype html><html ⚡><head>\n"
+ "<!doctype html><html ⚡ lang=en><head>\n"
+ "<!doctype html><html lang=en ⚡><head>\n"
+ "<!doctype html><html amp><head>\n"
+ "<!doctype html><html amp lang=en><head>\n"
+ "<!doctype html><html lang=en amp><head>\n"
+ "<!doctype html><html lang=en abc><head>\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}