re = /<html(?![^<>]* (?:amp|⚡)[ >])/m
str = '<!doctype html><html><head>
<!doctype html><html ⚡><head>
<!doctype html><html ⚡ lang=en><head>
<!doctype html><html lang=en ⚡><head>
<!doctype html><html amp><head>
<!doctype html><html amp lang=en><head>
<!doctype html><html lang=en amp><head>
<!doctype html><html lang=en abc><head>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end