$re = '/<html(?![^<>]* (?:amp|⚡)[ >])/m';
$str = '<!doctype html><html><head>
<!doctype html><html ⚡><head>
<!doctype html><html ⚡ lang=en><head>
<!doctype html><html lang=en ⚡><head>
<!doctype html><html amp><head>
<!doctype html><html amp lang=en><head>
<!doctype html><html lang=en amp><head>
<!doctype html><html lang=en abc><head>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);