using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\{\$\w+(?:\.\w+)+\}";
string input = @"{$variable.member}
awww{$variable..member...}awww
aww
{$variable}
{$variable.}
{$variable->member}
{$variable.member.}
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}