re = /\{\$\w+(?:\.\w+)+\}/m
str = '{$variable.member}
awww{$variable..member...}awww
aww
{$variable}
{$variable.}
{$variable->member}
{$variable.member.}
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end