package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\{\$\w+(?:\.\w+)+\}`)
var str = `{$variable.member}
awww{$variable..member...}awww
aww
{$variable}
{$variable.}
{$variable->member}
{$variable.member.}
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}