// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
  let regex = Regex::new(r"(?m)\{\$\w+(?:\.\w+)+\}").unwrap();
  let string = "{$variable.member}
awww{$variable..member...}awww
aww
{$variable}
{$variable.}
{$variable->member}
{$variable.member.}
";
  
  // result will be an iterator over tuples containing the start and end indices for each match in the string
  let result = regex.captures_iter(string);
  
  for mat in result {
    println!("{:?}", mat);
  }
}