$re = '/\{\$\w+(?:\.\w+)+\}/m';
$str = '{$variable.member}
awww{$variable..member...}awww
aww
{$variable}
{$variable.}
{$variable->member}
{$variable.member.}
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);