using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\S+)=""([^""\r\n]+)""|(\S+)='([^'\r\n]+)'";
string input = @"href='www.google.com' target=""_blank"" title=""S""
href=""javascript:alert('Hello');"",
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}