// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?mi)(\S+)="([^"\r\n]+)"|(\S+)='([^'\r\n]+)'"#).unwrap();
let string = "href='www.google.com' target=\"_blank\" title=\"S\"
href=\"javascript:alert('Hello');\",
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}