re = /(\S+)="([^"\r\n]+)"|(\S+)='([^'\r\n]+)'/mi
str = 'href=\'www.google.com\' target="_blank" title="S"
href="javascript:alert(\'Hello\');",
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end