$re = '/(\S+)="([^"\r\n]+)"|(\S+)=\'([^\'\r\n]+)\'/mi';
$str = 'href=\'www.google.com\' target="_blank" title="S"
href="javascript:alert(\'Hello\');",
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);