const regex = /(\S+)="([^"\r\n]+)"|(\S+)='([^'\r\n]+)'/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\S+)="([^"\\r\\n]+)"|(\\S+)=\'([^\'\\r\\n]+)\'', 'gmi')
const str = `href='www.google.com' target="_blank" title="S"
href="javascript:alert('Hello');",
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}