#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:\G(?!^)|^(?=(?:[^\d\n]*\b\d+\b){4}))[^\d\n]*\K\d+"
Local $sString = " 1 1 10 6" & @CRLF & _
" 1 43432 43 " & @CRLF & _
" 34343 " & @CRLF & _
"4343 64 5"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")