use strict;
my $str = ' 1 1 10 6
1 43432 43
34343
4343 64 5';
my $regex = qr/(?:\G(?!^)|^(?=(?:[^\d\n]*\b\d+\b){4}))[^\d\n]*\K\d+/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}