import re
regex = re.compile(r"(?:\G(?!^)|^(?=(?:[^\d\n]*\b\d+\b){4}))[^\d\n]*\K\d+", flags=re.MULTILINE)
test_str = (" 1 1 10 6\n"
" 1 43432 43 \n"
" 34343 \n"
"4343 64 5")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")