re = /(?:\G(?!^)|^(?=(?:[^\d\n]*\b\d+\b){4}))[^\d\n]*\K\d+/m
str = ' 1 1 10 6
1 43432 43
34343
4343 64 5'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end