const regex = new RegExp('(?:\\G(?!^)|^(?=(?:[^\\d\\n]*\\b\\d+\\b){4}))[^\\d\\n]*\\K\\d+', 'gm')
const str = ` 1 1 10 6
1 43432 43
34343
4343 64 5`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}