using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @" *while +\( *([a-z]\w*) *((?:!=|[=<>]=?)) *([a-z]\w*|\d+) *\) *";
string input = @"while ( b = 4 )
while ( b != 4 )
while (a==5)
while (a<=5)
while (a>=5)";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}