$re = '/ *while +\( *([a-z]\w*) *((?:!=|[=<>]=?)) *([a-z]\w*|\d+) *\) */i';
$str = 'while ( b = 4 )
while ( b != 4 )
while (a==5)
while (a<=5)
while (a>=5)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);