import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = " *while +\\( *([a-z]\\w*) *((?:!=|[=<>]=?)) *([a-z]\\w*|\\d+) *\\) *";
final String string = "while ( b = 4 )\n"
+ "while ( b != 4 )\n"
+ "while (a==5) \n"
+ "while (a<=5)\n"
+ "while (a>=5)";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}