import re
regex = re.compile(r" *while +\( *([a-z]\w*) *((?:!=|[=<>]=?)) *([a-z]\w*|\d+) *\) *", flags=re.IGNORECASE)
test_str = ("while ( b = 4 )\n"
"while ( b != 4 )\n"
"while (a==5) \n"
"while (a<=5)\n"
"while (a>=5)")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")