package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i) *while +\( *([a-z]\w*) *((?:!=|[=<>]=?)) *([a-z]\w*|\d+) *\) *`)
var str = `while ( b = 4 )
while ( b != 4 )
while (a==5)
while (a<=5)
while (a>=5)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}