# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/((?<!\d)\d\-\d{1,3})//g;t' <<< "5-2,5-12,15-27,5-22,50-3,5-100"