use strict;
my $str = '5-2,5-12,15-27,5-22,50-3,5-100';
my $regex = qr/((?<!\d)\d\-\d{1,3})/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";