$re = '/((?<!\d)\d\-\d{1,3})/';
$str = '5-2,5-12,15-27,5-22,50-3,5-100';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;