import Foundation
let pattern = #"((?<!\d)\d\-\d{1,3})"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"5-2,5-12,15-27,5-22,50-3,5-100"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)