re = /((?<!\d)\d\-\d{1,3})/
str = '5-2,5-12,15-27,5-22,50-3,5-100'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result