#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?i:p).*\.txt$"
Local $sString = "" & @CRLF & _
"P671_221.md" & @CRLF & _
"P671_221.txt" & @CRLF & _
"Z671_221.txt" & @CRLF & _
"" & @CRLF & _
"P6 712 21.py" & @CRLF & _
"P6 712 21.txt" & @CRLF & _
"06 712 21.txt" & @CRLF & _
"" & @CRLF & _
"P6AASF239FOaf71221.java" & @CRLF & _
"P6AASF239FOaf71221.txt" & @CRLF & _
"_6AASF239FOaf71221.txt" & @CRLF & _
"" & @CRLF & _
"P671221.pde" & @CRLF & _
"P671221.txt" & @CRLF & _
"12671221.txt" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")