using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?i:p).*\.txt$";
string input = @"
P671_221.md
P671_221.txt
Z671_221.txt
P6 712 21.py
P6 712 21.txt
06 712 21.txt
P6AASF239FOaf71221.java
P6AASF239FOaf71221.txt
_6AASF239FOaf71221.txt
P671221.pde
P671221.txt
12671221.txt
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}