// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?i:p).*\.txt$").unwrap();
let string = "
P671_221.md
P671_221.txt
Z671_221.txt
P6 712 21.py
P6 712 21.txt
06 712 21.txt
P6AASF239FOaf71221.java
P6AASF239FOaf71221.txt
_6AASF239FOaf71221.txt
P671221.pde
P671221.txt
12671221.txt
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}