re = /^(?i:p).*\.txt$/m
str = '
P671_221.md
P671_221.txt
Z671_221.txt
P6 712 21.py
P6 712 21.txt
06 712 21.txt
P6AASF239FOaf71221.java
P6AASF239FOaf71221.txt
_6AASF239FOaf71221.txt
P671221.pde
P671221.txt
12671221.txt
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end