use strict;
my $str = '
P671_221.md
P671_221.txt
Z671_221.txt
P6 712 21.py
P6 712 21.txt
06 712 21.txt
P6AASF239FOaf71221.java
P6AASF239FOaf71221.txt
_6AASF239FOaf71221.txt
P671221.pde
P671221.txt
12671221.txt
';
my $regex = qr/^(?i:p).*\.txt$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}