package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)\[(.+)?\] (.+?) (S\d* )?- (\d+) \[(.+)\]`)
var str = `[HorribleSubs] Fate Kaleid Liner PRISMA ILYA - 01 [720p]
[HorribleSubs] Akame ga Kill! - 02 [720p].mkv
[HorribleSubs] Aldnoah Zero - 08 [720p]
[HorribleSubs] Deadman Wonderland - 02 [720p]
[HorribleSubs] Tokyo Ghoul Root A - 01 [720p]
[HorribleSubs] Sword Art Online II - 02 [1080p]
[HorribleSubs] Yahari Ore no Seishun Love Come wa Machigatteiru Zoku - 07 [720p].mkv
[HorribleSubs] Love Live! S2 - 02 [720p]
[HorribleSubs] Fairy Tail S2 - 02 [720p].mkv`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}