const regex = /\[(.+)?\] (.+?) (S\d* )?- (\d+) \[(.+)\]/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[(.+)?\\] (.+?) (S\\d* )?- (\\d+) \\[(.+)\\]', 'gi')
const str = `[HorribleSubs] Fate Kaleid Liner PRISMA ILYA - 01 [720p]
[HorribleSubs] Akame ga Kill! - 02 [720p].mkv
[HorribleSubs] Aldnoah Zero - 08 [720p]
[HorribleSubs] Deadman Wonderland - 02 [720p]
[HorribleSubs] Tokyo Ghoul Root A - 01 [720p]
[HorribleSubs] Sword Art Online II - 02 [1080p]
[HorribleSubs] Yahari Ore no Seishun Love Come wa Machigatteiru Zoku - 07 [720p].mkv
[HorribleSubs] Love Live! S2 - 02 [720p]
[HorribleSubs] Fairy Tail S2 - 02 [720p].mkv`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}